뭐, 단순히 저를 위한 메모입니다만...


혹시나 필요하신분들도 계실거 같아서 일단 공개 해놓습니다. 뭐 아시는분은 다 아시겠지만...

제가 사용하는 환경은 JDE 4.6.0(9000 시뮬레이터를 사용하지요)입니다만, 다른 기기들도 마찬가지일듯...

4.7이나 5.0b에서는 어떨지 모르지만 4.6에서는 한글 폰트는 잘 깔리는데(예쁘지는 않지만...) 입력기가 아래와 같이 설치를 거부하는 경우가 있습니다.



특히... 한글입력기가 잘 설치되었다가도, clean한번 해주면 안되는 경우도...

뭐... 사용할 수 없는 응용 프로그램이 필요하다면, 강제로 읽어놓으면(아니면 읽은것 처럼) 하면 될거 같아서 다음과 같은 방법을 사용했습니다.


시뮬레이터 폴더에 9000.xml(뭐 이건 어떤기종 시뮬레이터냐에 따라 다르겠지요) 을 열어서... 아래와 같이 한줄 추가했습니다.


<Application>net.rim.platform.lang.ko</Application>
 

그럼 위와같이 추가되거나 업데이트 됩니다라고 뜹니다.

(한글폰트는 이런짓 안해도 그냥 설치되지만요...)

여기서 당황하지 말아야 할 점은... 설치가 끝나면 아래와같이...


Exception이 뜹니다만... 가볍게 무시하고 시뮬레이터를 종료합니다.

그냥 입력기를 설치하지 않고 이런식으로 입력기를 설치하면... 로컬라이제이션에 '한글'이 추가됩니다.

보통은 US나 UK만 나오지요.






여기까지 팁 같지도 않은 팁이었습니다.

한국에서는 블랙베리 어플리케이션 개발하시는분은 몇 없는건가요? 아니면 한글입력기가 필요없는 프로그램만 만드시는건지...

ps. 지난번 교육때 몇가지 기능에 대해 물었을때는 무조건 JDE 5.0에서 나온다고 해놓구선... 막상 JDE 5.0(베타이긴 하지만) API보면 별 차이도 없는거 같아요 ㅡㅡ;

ps2. 맥용 이클립스 플러그인이나 맥용 JDE는 언제 만들어 줄려는겨...
Posted by iStpik